Όλες οι Ερωτήσεις στο PCstepsΚατηγορία: WindowsΠροβλημα με την ωρα στα windows 10
Dimitris ρώτησε πριν 5 έτη

Καλησπέρα. Στα windows 10 έχω ενα παράξενο πρόβλημα σε 2 διαφορετικά pc.Το ρολόι σχεδόν κάθε φορά που ανοίγω το pc το βρίσκω 2 η 3 ώρες πισω.Εχω κανει τα πάντα από ρυθμίσεις, έχω επιλέξει αυτόματη και όχι αυτόματη ρύθμιση ώρας, έχω επιλέξει αυτόματα και όχι αυτόματος ορισμός ζώνης ώρας και αυτόματη προσαρμογή θερινής ωρας. Επισεις έχω δοκιμάσει και τους 2 Server για αυτόματο συγχρονισμό μέσω internet. Ότι και να έχω κάνει η ώρα χαλάει, η μπαταρία δεν είναι γιατί είναι αλλαγμένη. Αλλά αν ήταν θα είχα πρόβλημα και στα windows7 γιατί εκεί η ώρα δεν χαλαει. Τι μπορεί να φταίει και μου έχει σπάσει τα νεύρα? Έχει και άλλος αυτό το πρόβλημα η εμφανίζεται μόνο σε μένα?

8 Απαντήσεις

Γιώργος Λάνδρου Staff απάντησε πριν 5 έτη

Καλησπέρα Φίλε μου, έχεις επιλέξει σωστή ζώνη ώρας ? Ρίξε μια ματιά και εδώ:

1

2

3

Dimitris απάντησε πριν 5 έτη

Το πρόβλημα το παρουσιάζει μόνο σε dual boot απ οτι έψαξα και στο google.Και η microsoft δεν απαντάει με σαφήνεια ποια ειναι η αιτία. Όταν μπω πχ στα 7 ας πούμε ρυθμίζω την ώρα σωστά. Κάνω επανεκκίνηση και μετά μπαίνω στα 10. Οταν επιστρέψω ξανά στα 7 το ρολόι ειναι 3 ώρες πίσω. Το ίδιο παρουσιάζει και με τον αντίστροφο τρόπο. Δεν γνωρίζω αν το πρόβλημα παρουσιάζεται μόνο αν έχουμε 1 σκληρό με 2 partition και αν σε εγκατάσταση με 2 διαφορετικούς σκληρούς είναι οκ. Καθώς και στα 2 pc μου τα εχω σε ένα δίσκο. 
Τι να πω είναι αρκετά περίεργο αυτό που συμβαίνει και απορώ πως δεν εχει βρεθεί ακόμα η αιτία. Να φταίνε τα 10 να υπάρχει κάποιο bug? Γιατί τόσα χρόνια με τα 7 αν ήταν εκεί η αίτια σιγουρα θα το είχαν διορθώσει. 

Patrick Matvei απάντησε πριν 5 έτη

Προσωπικα διαθέτω 4 υπολογιστες σε Dual Boot(10αρια -7αρια) .Στον ένα δε εχω τρια λειτουργικα(10αρια-8αρια-7αρια) σε ένα δισκο και ποτε δεν αντιμετωπισα κανενα απολυτως πρόβλημα.
Τωρα στο πρόβλημα πιστευω οι λογοι μπορει να είναι αρκετοι και πρεπει να πειραματιστείς με διαφορες λυσεις

Dimitris απάντησε πριν 5 έτη

Τι να κάνω δηλαδή? Εχω κάνει τα πάντα και εχω αλλάξει της ρυθμίσεις δεκάδες φορές. Και γιατί όσες φορές μπαίνω πχ μόνο στα 7 συνέχεια δεν χαλάει η μόνο στα 10 δεν χαλάει και το παρουσιάζει μόνο όταν κάνω την αλλαγή? Αν ήταν θέμα δίκης μου λάθος ρύθμισης θα χάλαγε η ώρα και όταν άνοιγα και έκλεινα το pc στο ίδιο λειτουργικό. Αλλά οπως είπα ετσι μου δουλεύει σωστά…. 
Εδώ πάντως αναφέρουν ότι το προβλημα οφείλετε στο dual boot. 
https://www.tenforums.com/general-support/28770-windows-10-time-keeps-changing.html

Patrick Matvei απάντησε πριν 5 έτη

Δες εδώ  https://www.computerhope.com/issues/ch000239.htm
Εάν εχεις Ντεσκτοπ μπορει να είναι και το τροφοδοτικο

Dimitris απάντησε πριν 5 έτη

Φίλε μου σορρυ αλλα αυτό που λες δεν στέκει. Δεν μπορει να εχω 3 pc και να παρουσιάζουν ακριβώς το ίδιο πρόβλημα…. Στο Σπιτι μου το δικο μου pc, στο μαγαζι που εργαζομαι τα ιδια αλλα και ενα netbook που εχω, ολα με dual boot και ειναι χαλασμένα?? Δεν παίζει αυτό με τίποτα. Αν το προβλημα το είχα στο ένα από όλα, οκ θα το καταλάβαινα…

Dimitris απάντησε πριν 5 έτη

Μετά από αρκετό ψάξιμο στα forums την βρήκα την λύση στο πρόβλημά μου και την παραθέτω για τυχών βοήθεια προς άλλους. Το πρόβλημα παρουσιάζεται και σε linux και συγκεκριμένα σε ubuntu σε dual boot με windows. Από τα λίγα αγγλικά μου κατάλαβα ότι κάτι εχει να κάνει με το UTC (τον συγχρονισμό της ώρας με τον παγκόσμιο χρόνο.)  
Η λύση είναι η παρακάτω.
Κάνουμε δεξί κλικ στην επιφάνεια εργασίας και επιλέγουμε (έγγραφο κειμένου). Κάνουμε paste αυτό εδώ.
Windows Registry Editor Version 5.00 [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation] “RealTimeIsUniversal”=-
Και το κάνουμε save σαν WindowsTimeFixUTC.reg Tο τρέχουμε ώστε να καταχωρηθεί στο μητρώο των windows και κάνουμε επανεκκίνηση. Μπαίνουμε και στο δεύτερο λειτουργικό και κάνουμε ακριβώς το ίδιο με το αρχείο. Διορθώνουμε την ώρα και μπαίνουμε ξανά στο άλλο λειτουργικό και κάνουμε και εδώ διόρθωση της ώρας. Και κατά πάσα πιθανότητα μετά από αυτό το πρόβλημα θα λυθεί.
Αν εχουμε linux γράφουμε της εντολές σε παράθυρο τερματικού που υπάρχουν στο αγγλικό κείμενο.
Σε μένα μέχρι στιγμής τουλάχιστον που το δοκίμασα του έκανα 5-6 επανεκκινήσεις στα 7 και στα 10 και επιτέλους η ώρα δεν μου ξαναχάλασε…
Multiple Boot Systems Time Conflicts
Operating systems store and retrieve the time in the hardware clock located on your motherboard so that it can keep track of the time even when the system does not have power. Most operating systems (Linux/Unix/Mac) store the time on the hardware clock as UTC by default, though some systems (notably Microsoft Windows) store the time on the hardware clock as the ‘local’ time. This causes problems in a dual boot system if both systems view the hardware clock differently.
The advantage of having the hardware clock as UTC is that you don’t need to change the hardware clock when moving between timezones or when Daylight Savings Time (DST) begins or ends as UTC does not have DST or timezone offsets.
Changing Linux to use local time is easier and more reliable than changing Windows to use UTC, so dual-boot Linux/Windows systems tend to use local time.
Since Intrepid (8.10), UTC=yes is default.
Make Windows use UTC
Note: This method was not initially supported on Windows Vista and Server 2008, but came back with Vista SP2, Windows 7, Server 2008 R2 and Windows 8/8.1.
To make MS Windows calculate the time from the hardware clock as UTC.
Create a file named WindowsTimeFixUTC.reg with the following contents and then double click on it to merge the contents with the registry:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
     "RealTimeIsUniversal"=dword:00000001

Note: Windows Time service will still write local time to the RTC regardless of the registry setting above on shutdown, so it is handy to disable Windows Time service with this command (if time sync is still required while in Windows use any third-party time sync solution):

sc config w32time start= disabled

Reversing the change
You can create a file with the following contents and then double-click it to merge in the original changes, as above:

Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
     "RealTimeIsUniversal"=-

If Windows Time service was disabled, enable it again with the command:

sc config w32time start= demand

Make Linux use ‘Local’ time
To tell your Ubuntu system that the hardware clock is set to ‘local’ time:
Pre-Ubuntu 15.04 systems (e.g. Ubuntu 14.04 LTS):

  1. edit /etc/default/rcS
  2. add or change the following section

    # Set UTC=yes if your hardware clock is set to UTC (GMT)
    UTC=no
    

Ubuntu 15.04 systems and above (e.g. Ubuntu 16.04 LTS):

  1. open a terminal and execute the following command

    timedatectl set-local-rtc 1

Christopher Ntikas απάντησε πριν 3 έτη

Το ίδιο πρόβλημα έγινε και σε εμένα από τότε που έβαλα ubuntu 18.04 σε δεύτερο δίσκο με windows 10 64bit στον πρώτο.